User Tools

Site Tools


client:client_compiling

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
client:client_compiling [2019/08/04 01:51]
leaf Package dependency listing for GTKv2 client on Linux Mint 19.2 (Tina)
client:client_compiling [2019/11/18 16:10] (current)
leaf Client compile update for Fedora 31
Line 52: Line 52:
  
 A quick reference for Debian 9 (Stretch): A quick reference for Debian 9 (Stretch):
 +  apt install cmake libcurl4-openssl-dev libgtk2.0-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev pkg-config subversion valac
 +  ​
 +==== Debian 10 (Buster) ====
 +
 +A quick reference for Debian 10 (Buster):
   apt install cmake libcurl4-openssl-dev libgtk2.0-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev pkg-config subversion valac   apt install cmake libcurl4-openssl-dev libgtk2.0-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev pkg-config subversion valac
 ==== Fedora 25 ==== ==== Fedora 25 ====
Line 82: Line 87:
  
 A quick reference for Fedora 30 using the command line interface: A quick reference for Fedora 30 using the command line interface:
 +  sudo dnf install cmake gtk2-devel libcurl-devel make SDL_image SDL_image-devel SDL_mixer SDL_mixer-devel subversion vala
 +  ​
 +==== Fedora 31 ====
 +
 +A quick reference for Fedora 31 using the command line interface:
   sudo dnf install cmake gtk2-devel libcurl-devel make SDL_image SDL_image-devel SDL_mixer SDL_mixer-devel subversion vala   sudo dnf install cmake gtk2-devel libcurl-devel make SDL_image SDL_image-devel SDL_mixer SDL_mixer-devel subversion vala
 ==== Linux Mint 17.3 (Rosa) ==== ==== Linux Mint 17.3 (Rosa) ====
Line 177: Line 187:
 A quick reference for Peppermint 10: A quick reference for Peppermint 10:
   sudo apt install cmake libcurl4-openssl-dev libgl1-mesa-dev libgtk2.0-dev libsdl-image1.2-dev libsdl-mixer1.2-dev mesa-common-dev pkg-config subversion valac   sudo apt install cmake libcurl4-openssl-dev libgl1-mesa-dev libgtk2.0-dev libsdl-image1.2-dev libsdl-mixer1.2-dev mesa-common-dev pkg-config subversion valac
 +
 +===== Ubuntu =====
 +
 +The dependency and instructions for the listed versions of Ubuntu includes or applies to all the different flavours including:
 +  * Kubuntu
 +  * Lubuntu
 +  * Ubuntu Budgie
 +  * Ubuntu Mate
 +  * Xubuntu ​
  
 ==== Ubuntu 14.04 LTS (Trusty Tahr) ==== ==== Ubuntu 14.04 LTS (Trusty Tahr) ====
Line 211: Line 230:
  
 A quick reference for Ubuntu 19.04 (Disco Dingo): A quick reference for Ubuntu 19.04 (Disco Dingo):
 +  sudo apt install cmake libcurl4-openssl-dev libglade2-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libgtk2.0-dev subversion valac
 +  ​
 +==== Ubuntu 19.10 (Eoan Ermine) ====
 +
 +A quick reference for Ubuntu 19.10 (Eoan Ermine):
   sudo apt install cmake libcurl4-openssl-dev libglade2-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libgtk2.0-dev subversion valac   sudo apt install cmake libcurl4-openssl-dev libglade2-dev libsdl1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libgtk2.0-dev subversion valac
 ===== Obtaining the Source ===== ===== Obtaining the Source =====
client/client_compiling.1564901480.txt.gz ยท Last modified: 2019/08/04 01:51 by leaf