Gridarta

Introduction

Gridarta is a project that merges CFJavaEditor from Crossfire with its derivate DaimoninEditor from Daimonin, started in May 2006 by Cher, Ragnor, and Zergus.

Status

There have been no official releases of Gridarta yet. Most of the current effort seems to be going towards merging and cleanup on both sides. This table gives a rough idea of how much code is merged currently:

Section Lines (including blank and commented)
Merged Code (excluding textedit) 15275
Merged Code (including textedit) 23206
Gridarta4Crossfire Code 25230
Gridarta4Daimonin Code 28566
Lines in Gridarta4Crossfire that differ from Daimonin 12366
Lines in Gridarta4Daimonin that differ from Crossfire 16063
Last updated 2007/01/22 18:45 (Gridarta rev 1667)

See also: Gridarta Merge Statistics Page

Getting Gridarta

Gridarta can be retrieved from svn with:

  svn co https://gridarta.svn.sourceforge.net/svnroot/gridarta

Also, there are following ‘unoffical’ gridarta builds:

Installing Gridarta on Windows

Building and Running Gridarta

To build Gridarta, you need to use the Apache Ant build system, and Java 1.5.0 or higher is required to both build and run Gridarta.

Building Gridarta4Crossfire

Inside of the Gridarta source directory, run:

cd crossfire
ant

Building Gridarta4Daimonin

cd daimonin
ant

Running Gridarta

Gridarta can be run or launched through the following methods:

CLI (Command Line Interface)

For Gridarata4Crossfire run:

java -jar CrossfireEditor.jar

or for Gridarta4Daimonin run:

java -jar DaimoninEditor.jar

Also, it is possible java may not allocated enough memory defaultly, in which case use “-Xmx128M” or similar in the parameters to Java. For larger machines, explicitely requesting a client type VM can significantly speedup gridarta, so consider using “-client“.

GUI (Graphical User Interface)

Double click on the .jar file - this is the case for Windows based systems and also applies for MacOS X.

Special Instructions & Troubleshooting

ant setup

JRE Update

*nix Based

If you recently upgraded your Java JRE or having problems launching the editor, or would like to specify a particular version of Java, run this command:

$ update-alternatives --config java

Follow the instructions that appear: NOTE: actual output, contents and options will vary, you’ll want to use: /usr/lib/j2re1.5-sun/bin/java

 There are 6 alternatives which provide `java'.
 
  Selection    Alternative
 -----------------------------------------------
          1    /usr/lib/j2re1.4-sun/bin/java
 *        2    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
          3    /usr/bin/gij-wrapper-4.0
 +        4    /usr/lib/jvm/java-gcj/jre/bin/java
          5    /usr/bin/gij-wrapper-4.1
          6    /usr/lib/j2re1.5-sun/bin/java
 Press enter to keep the default[*], or type selection number: 6
 Using `/usr/lib/j2re1.5-sun/bin/java' to provide `java'.

Then try launching the editor again.

MacOS X Based

  • If you want to switch between ‘released’ version of java, just run the ‘Java Preference.app’, spotlight Java and you’ll get a hit.
  • If you want to run a Developer Preview (DP) release you’ll need to do some tweaking. See below.
  • You can get Fancy with some bash scripting
Developer Preview of Java

Apple does not want the normal user to run a DP version of java, so the pretty GUI and neat way of switching releases is disabled. Apple’s official mechanism is to use full path to the release of java you want to run.

* Command line example to run 1.6

$ /System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands/java -version

This should display something like the following:

   java version "1.6.0_01-dp"
   Java(TM) SE Runtime Environment (build 1.6.0_01-dp-b06-101)
   Java HotSpot(TM) 64-Bit Server VM (build 1.6.0_01-41-release, mixed mode)

* Make 1.6 your “default” for the command line

  $ vi ~/.bash_profile
  PATH="/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands:${PATH}"

Then run:

 
   $source ~/.bash_profile
   $java -version

You are now able to use java 1.6 at terminal.

FIXME– * Make 1.6 your “default” for the GUI ‘UNTESTED

  1. Open the Finder and navigate to a .class and/or .jar file
  2. Right click on the file and select ‘Get Info’
  3. Expand the ‘Open With:’ option
  4. Change ‘Jar Launcher (default)’ to your preferred version of java
  5. Be bold and click ‘Change All...’

Blank Editor Screen

Enter the following command in the same terminal or shell window and then try running the client:

$ export AWT_TOOLKIT=MToolkit

Links

 
gridarta.txt · Last modified: 2013/11/02 22:24 by saru
 
Recent changes RSS feed Powered by PHP Valid XHTML 1.0 Valid CSS Debian Driven by DokuWiki